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1 A few words about FreeCAD
FreeCAD is a parametric 3D modeler, free and open-source (under the LGPLv2+ license) that
has been under continuous development since 2002. FreeCAD has an organisation in work-
benches and features similar to CATIA, Creo, Autodesk Inventor, SolidWorks or Solid Edge.
FreeCAD uses extensively other open-source libraries from the field of scientific computing
such as Open CASCADE (a CAD kernel), Coin3D (an incarnation of Open Inventor) and the
Qt GUI framework. In addition FreeCAD can be controlled from Python which allows for
scripting or use of FreeCAD itself as a python module. The stable version you should use in
the course is v16 or higher. The tutorials are written for v16, so small changes in the GUI may
happen if you use a higher version.

FreeCAD is hosted on GitHub (https://github.com/FreeCAD). For a quick tour see the
FreeCAD homepage (http://www.freecadweb.org/).

Learning a bit of FreeCAD is a good investment of your time. If you work with numerical
simulations of realistic engineering components or systems, you will either have to use CAD or
interact closely with people building CAD models for you. While there are many other CAD
tools than FreeCAD, the general way of thinking is quite similar. More pragmatically, you will
need to do a bit of CAD in the 3D printing module of the Fluid Mechanics course.

2 Installation
You should read this section if you want to install FreeCAD on your personal computer. If you
cannot / do not want to install FreeCAD on your computer, it is also available as a module on
the UiO Linux computers of the department.

General installation instructions for all OSs are given on the FreeCAD website, but read the
whole present section before you install anything. In all the following, it will be assumed that
Linux (Debian or Debian based distribution such as Ubuntu) is used. This is recommended as
FreeCAD is most stable on Linux (several annoying bugs were observed on Windows, including
failure to save work... Mac was found stable). If you want to install FreeCAD on Windows or
Mac, follow the instructions given on their website:

http://www.freecadweb.org/wiki/index.php?title=Install_on_Windows
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http://www.freecadweb.org/wiki/index.php?title=Install_on_Mac

It is not recommended to install FreeCAD from the package manager of you Debian distri-
bution, as the version packaged may be quite old (using sudo apt-get on Ubuntu 16.04LTS
you will get v15, which do misses some important features present in v16). It is recommended
to install the latest stable release version. This can be done following the instructions on
FreeCAD webpage:

http://www.freecadweb.org/wiki/index.php?title=Install_on_Unix

Follow the instructions of the Latest Stable Release from the stable releases" PPA or
"daily" PPA section. Install the version corresponding to the stable PPA, typing:

$ sudo add−apt−r e p o s i t o r y ppa : f r eecad−mainta iner s / f r eecad−s t ab l e
$ sudo apt−get update
$ sudo apt−get upgrade
$ sudo apt−get i n s t a l l f r e e cad f reecad−doc

3 Getting started
FreeCAD is supported by a growing community and many presentations, tutorials and forum
discussions are available online. Here I will give a very basic introduction to get you started
and I will refer to online tutorials and manuals if you need more details.

3.1 Open FreeCAD
To open freecad on UiO Linux computers, you will have to first load the freecad module:

$ module load f r e e cad /0 .16 . 6706
$ FreeCAD

The name of freecad module may change (if its version gets updated), but you can always list
all available modules with:

$ module a v a i l

To open freecad on your computer, just open a terminal and type:

$ f r e e cad

This will take you to the FreeCAD start center. There you can either choose some of the
options displayed on the main panel to get some FreeCAD introduction, or directly start
working. You can open an existing project through the File>Open... menu or using the icon.
You can create a new project through File>New or using the icon. For now we will consider
that you opened a new project.
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Figure 1: Selecting the right workbench is the most important step to get to build a good model.

3.2 Workbenches
The first key concept to understand about freecad is the notion of workbenches. A workbench
is a collection of tools that make it easy to realize a task. You can select a workbench through
the drop down menu in the icon bar, see Fig. 1. In the 3D printing module you will mostly
use the Part Design and the Part workbenches. You should get more familiar with the
workbenches available by reading at least the following documentations pages:

http://www.freecadweb.org/wiki/?title=Workbenches

http://www.freecadweb.org/wiki/index.php?title=Part_Module

http://www.freecadweb.org/wiki/index.php?title=PartDesign_Workbench

4 Example 1: using the Part workbench, primitives and
FreeCAD most important tabs

Let us take a simple example. Here you will create a simple shape in FreeCAD.

• Click on the Create a new empty document button.

• Select the Part workbench

• Click the Create a Cylinder button. Note that the buttons space can become overpop-
ulated and then some buttons are hidden. You can solve this by moving around button
arrays by draging and dropping the vertical three dots visible before each button array.

• Click the Set to axonometric view (0) button
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• Select the cylinder you just created. For this, click on the Cylinder line in the Model
tab of the Labels & Attributes panel.

• You can Delete, Rename etc the cylinder you just create by right clicking on the Cylinder
line. Rename the cylinder into TubeVolume.

• In the Data tab, you can edit properties of the selected object. For our newly created
TubeVolume, this includes placement, label (that we already changed), and the properties
that define the cylinder (Radius, Height, Angle). Set Radius to 4 mm by clicking on the
field and typing the value. Set height to 20 mm.

• Now the cylinder is too big for your screen. You can train to move the camera relatively
to the shape. Read and follow the instructions of the manual:

http://www.freecadweb.org/wiki/index.php?title=Mouse_Model

I advice you to use the defaults and to use a mouse (touchpad is not very adapted for
working on CAD). You can also navigate the views by using the icons Set to [...] view
and Fit the whole content on screen to get right zoom factor and axonometric or
standard camera positions.

• Create a new cylinder, call it TubeInside and set a radius of 2 mm and a heigth of
20 mm.

• Select first the TubeVolume you created and then, holding the Ctrl key, the TubeInside
so that both shapes are selected at one. Then, click the Make a cut of tow shapes
button. This will create a new object, called Cut, in the Model tab. Rename it to Tube.
You can expand the details of you Tube by clicking on the little triangle before its name.
You can then display the hierarchical graph of you object. The graphical display of your
object should look like in Fig. 2

• The underlying objects are still available and can still be accessed. They appear greyed in
the Model tab as they are currently not displayed on screen. Click on TubeInside. Change
the radius to 3 mm. The Tube object gets automatically updated. While TubeInside is
selected, go to the View tab instead of the Data tab. There you can affect properties
that have an effect on the rendering of your shapes. Set Visibility to True by clicking
on the option. Toggle back the visibility to False by pressing space on your keyboard.

• Now we can change the placement of our object. Select the Tube object. Click on the
Placement option in the Data tab, and open the detailed selection box by clicking the
... symbol. If your tab is too narrow, you can rescale it by moving its right edge. The
placement options are described in the manual:

http://www.freecadweb.org/wiki/index.php?title=Placement

Take a look at the manual and get familiar with the effect of each field. Then, apply a
Translation of 3 mm in the Z direction and a 20 degrees rotation around the Y axis.
Press OK to save you changes.
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Figure 2: The goal of Tutorial 1: build a pipe from a boolean difference.

• You can save your work through the File>Save menu. This will save as a .fcstd, i.e.
”FreeCad STanDard”. You can export an object in many other formats by selecting the
name of the object to export in the Model tab and then going through the File>Export
menu. You can select between many file types. Most often in the 3D printing module you
will use the Alias Mesh (*.obj) or the STL Mesh (*.stl) to export to the form labs
software.

This should have given you an overview of some of the important panels and tabs of the
standard FreeCAD window.

5 Example 1 bis: another way to design pipes
Often in CAD there are many ways to attain a given result. In the Example 1 we build a
cylindrical pipe by taking the boolean difference between two solids. But FreeCAD also has
a function that lets you perform the same task in one single step. First, start reading the
FreeCAD documentation about the Utility to apply a thickness:

http://www.freecadweb.org/wiki/index.php?title=Part_Thickness

You should understand that this is well suited to build cylinders! Start a new document and:

• Move to the Part Workbench.

• Create a cylinder and select its top face by clicking on it in the main view window.

• Click on the Utility to apply a thickness button. The shape gets updated and you
enter a dialog box looking like in Fig. 3 to set the fine tuned options of the tool. You can
move around the modified cylinder to observe it. It is not yet a tube, so we should work a
bit with the dialog box to get what we want.
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Figure 3: Dialog boxes are often used by FreeCAD to get user input.

• Click the Faces button in the dialog box. This will reset the view to the full cylinder.
Select the top face and the bottom face of the cylinder by clicking one and then the other
face while holding the crtl key. Then click Done in the dialog box. You now have a tube.
You can adjust its Thickness by adjusting the corresponding option in the dialog box.
Click Ok in the dialog box when you are satisfied with the result.

This small example should convince you to read quickly through FreeCAD documentation
and to not hesitate to look for a bit of help on the FreeCAD forum before you start using a
clumsy solution for designing your part! For example, if you should work with tubes in the
future, look also at the documentation around the Join walled objects button!

6 Example 2: using the Part Design workbench and
sketcher

Similarly to many other CAD tools, a powerful feature of FreeCAD consists in creating 2D
geometries to extend them into 3D shapes. Here, I will take you through a simple example.
But first, you shoud have a good look at the Sketch Workbench manual and go through the
different buttons descriptions:

http://www.freecadweb.org/wiki/index.php?title=Sketcher_Workbench

• Create a New document

• Select the Part Design workbench

• Click the Create a new sketch button, then choose XY-Plane.

• We will draw a simple shape in 2D. Start by creating two lines, then one arc and one
more line as indicated in Fig. 4. Note that if you create a line that is nearly horizontal,
FreeCAD will automatically add it an horizontal constraint (visible as an additional
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horizontal line icon next to your pointer). The same is true for vertical constraint. If you
want to make some point of your current shape coincident with another point or line, click
on it so that it gets highlighted. If FreeCAD does not get what you want and does not
automatically enforce some constraints, this is not a problem - you can do it in the next
step.

• Now that we have created a simple shape, we want to add constraints on it. First, we
want to make it closed. For this, select the start and end points of your sketch (by clicking
one then the other while pressing ctrl) and press the Create a coincident constraint
button. The line at the top of your sketch should be horizontal (indicated by a small
red icon next to it). If this is not the case, select the line and click on the Create a
horizontal constraint button. Make sure the same way that the vertical line is vertical.

• Constraints are displayed in the main view and in the Task tab in the Constraints tile.
By right clicking on a constraint you can delete or edit it. The Solver messages tab
gives you indications about the current state of your sketch (under constrained, fully
constrained, over constrained).

• Click on the arc of circle and then on the Fix the radius button. Set the circle radius to
15 mm. You can move the position of the 15 mm label by dragging it around. If you do
not see the Fix the radius button, it probably means it is hidden in the buttons array -
drag the constraints button array to a place with more space.

• Similarly, set the length of the horizontal and vertical lines (this can be done with the Fix
the horizontal distance and the Fix the vertical distance buttons, or with the Fix
a length button), the angle between the horizontal and the inclined line (use the Fix
the angle button), make the top left corner of your sketch coincident with the origin,
and set the angle of the arc of circle. Your sketch should then be fully constrained and
turn green. Drag the labels around so that you sketch looks like the picture in Fig. 5.

• We can illustrate what happens if you try to make your sketch over constrained. Try to
set the length of the inclined line to 50 mm. You will get an error message.

• Now that we have a 2D shape, let us make it 3D! Close the sketch editor, move to the
Labels & Attributes tab. Rename your sketch to Base. Select your sketch, and click
on the Pad a selected sketch button. This will open a dialog box. Set the Length
of your pad to 150 mm and click Ok. Take a look at your new 3D shape by moving it
around.

• Select your newly created Pad in the Labels & Attributes tab. Observe that you can
set its properties through the Data tab. Set the length to 160 mm. You could also
change, for example, its placement. Similarly you have access to the View tab. Set
Transparency in the View tab to 50. Click in some empty part of the display view and
move your solid around.

• Let us now say that we want to drill a hole in our shape, perpendicularly to the inclined
face. Click on the inclined face to select it. Then, while it is selected, click on the Create
a new sketch button. This will open the sketch editor with the plane in which you will
be sketching set as the face that was selected. Move around as shown on Fig. 6 to get
convinced about that. Once you are done looking at the position of your sketch in 3D,
click on the View sketch perpendicular to sketch plane button to come back to a
normal view.
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Figure 4: This is how a sketch will typically look like before you set constraints.

• Use the Create a Rectangle in the sketch button and set constraints to get a fully
constrained sketch. You can use the Create a lock constraint button to set at once the
X and Y position of the left bottom side of the rectangle. Click close when you are done.

• Back in the main view, select your new sketch and press the Create a pocket button.
Set the type as Through all and press Ok. You can now check the results by navigating
in 3D.

• Save the current state of your project (use the .fcstd), as we will continue building on it
later on.

7 Example2 (continuation): A few more advanced sketch
and 3D shape creation tools

By now you should already be familiar with the sketch tool and how to extend a 2D geometry
into 3D. In addition, you should understand that the best way to get efficient is to read
(quickly) through the documentation and discussion forum to get aware of what can be done
using FreeCAD built in functionalities. However I will still help you a bit with a few sketcher
and 3D shape creation tools.

• Open the project as you got it at the end of the Example 2. Move to the Part design
workbench.

• Select the lateral face of your object, see Fig. 7. Create a new sketch there. As you can
see, the part is still displayed under the sketch but you cannot access any of its edges. For
this, we need to import some edges from the 3D object into the 2D sketch.

• Click the Create an edge linked to an external geometry button and then the
inclined side of the 3D object. The edge will then turn purple, and you will gain access to
it in the sketch.

J. Rabault
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Figure 5: A fully constrained sketch turns green.

Figure 6: A sketch can be created on any planar face.
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Figure 7: We will build our next sketch on a lateral face of our model.

• Build a sketch similar to the one shown in Fig. 8. Note that the imported external edge
is available for connecting points on it and using as a constraint but is not a part of the
sketch, so you will need to build a line on top of it to get a closed shape that can be
extended to 3D. Close the sketcher. Rename the sketch as SketchBase.

• We will extend the geometry to 3D using a more sophisticated tool. Create a new sketch
in the XZ plane, i.e. normal to your previous sketch. Build a sketch that looks like Fig 9.
Note that the horizontal line is a construction line to set the position of the circle center.
Close the sketch. Rename the sketch as SketchPath.

• Move to the Part Workbench. Click on the Utility to sweep button. In the Sweep
tab, select the SketchBase and move it to the Sweep tab using the GUI arrow to the
right. Then click on Sweep Path. Select the vertical line and arc of circle from the
SketchPath in the graphical view window, holding the ctrl key pressed. Click Done.
Click Ok.

• Inspect the shape you obtain in the 3D view. By default, FreeCAD generated an empty
shell. Select the Sweep you just created in the Labels & Attibutes tab, and in the
Data box set the Solid parameter to True. This will update you shape into a solid. It
should look like Fig. 10. Here we generated a bulky looking shape, but this utility could
be ideal to generate, for example, wings. Have a look in more details at the documentation
for both the Utility to loft and the Utility to sweep.

There are afew more sketcher functions that you should look at by yourself, in particular
the Toggle the toolbar or selected geometry to/from construction mode, the Trim
an edge with respect to the selected position and the Fillet functions.

8 Example 4: using spreadsheet and formula
A neat functionnality available from FreeCAD v16 and upper is the possibility to use formula
to define construction lengths, angles etc and to group the definition of those parameters in
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Figure 8

Figure 9
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Figure 10

a spreadsheet. This way you can very easily build a parametric CAD model and generate
different versions of your object by changing one or more attributes from the spreadsheet. We
will illustrate this with a very simple example.

• Open an new project and go to the Part workbench.

• Create a Cone solid.

• Move to the Spreadsheet workbench and click on the Create a new speadsheet
button. Open the speadsheet by double clicking on it in the Labels & Attibutes tab.

• The speadsheet works like any Excel-like tool. Get to a result similar to the one shown
in Fig. 11. This is an engineering tool, units are important!! Right click on the cells
which each of the values, enter the Properties tool. There, go to the Alias tab and enter
the name of the parameter. The cell will get yellow to indicate that it is linked to an alias.
Do this for all cells.

• Now that the aliases are defined, you can use them to set properties in your sketches and
solids. In the Data tab, left click on the Radius1 parameter of your Cone. The data
filed will get available for setting a value, and you can notice that a small icon looking
like a function symbol gets available on the right of the value box. Click on the function
symbol and enter the name of the parameter you want to use. Note that you will have
to use a Python-like convention, i.e. Spreadsheet.param_radius_1 will refer to the
param_radius_1 defined in the Spreadsheet file. Click Ok. Do this for all three
parameters Radius1, Radius2 and Height of the cylinder.

• Change some parameters in the spreadsheet. This will automatically update the parameters
in your data field and the 3D view of your cone.

Here we used a speadsheet and formula in a very simple case, but this is a powerful feature
when you get to a complex geometry with many parameters. The formula can use all usual
mathematical functions, have a look at the documentation for more information.
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Figure 11

9 Going further
You know have used some of the most important features of FreeCAD including the Part,
Part Design and Sketcher workbenches, as well as spreadsheet for easily controlling the
parameters of your model. Often in CAD there are many ways of building a given geometry,
and you should practise to get better. Google is your friend when working on CAD: search the
internet for FreeCAD tutorials, videos, forum etc.
Since repetition is the mother of any learning, I strongly advise you to take a look at the

FreeCAD manual:

https://www.gitbook.com/book/yorikvanhavre/a-freecad-manual/details

And the following on line tutorials:

Bram de Vries FreeCAD tutorials on Youtube:

https://www.youtube.com/playlist?list=PLVrqzKSVAONHYXc9G9y9wHWus3ManpzUn

FreeCAD lessons for beginners channel on Youtube:

https://www.youtube.com/playlist?list=PL6fZ68Cq3L8k0JhxnIVjZQN26cn9idJrj
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